頂部左側

出現紅色標記,給個選股公式(圖文)行情軟件

2019-12-22 21:23:50 閱讀()
導讀:編寫要求: www.guhai.com.cn股海 網解答: 網友求助:指標公式源碼: 把出現紅色箭頭的選股公式 RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*247.2-123.6;{DRAWBAND(3

編寫要求:

 

www.guhai.com.cn股海 網解答:

 網友求助:

指標公式源碼: 把出現紅色箭頭的選股公式

 

出現紅色標記,給個選股公式
RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*247.2-123.6;
{DRAWBAND(3*(SMA(SMA( RSV,3,1),3,1))-2*(MA(EMA(SMA(SMA( RSV,3,1),3,1),3),3)),RGB(255,0,255),SMA(SMA( RSV,3,1),3,1),RGB(0,255,0));
DRAWBAND(SMA(SMA( RSV,3,1),3,1),RGB(0,255,0),3*(SMA(SMA( RSV,3,1),3,1))-2*(MA(EMA(SMA(SMA( RSV,3,1),3,1),3),3)),RGB(255,0,255));
DRAWBAND(SMA(SMA( RSV,3,1),3,1),RGB(0,0,255),MA(EMA(SMA(SMA( RSV,3,1),3,1),3),3),RGB(255,255,0));}
SQX:=(C-MA(CLOSE,13))*100;
DIF:=EMA(MA(SQX,7),1);
DEA:=EMA(DIF,7);
MACD:=(DIF-DEA)*2;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.1,0),COLORRED;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.1,0),COLORWHITE;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.1,0),COLORBLUE;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.1,0),COLORBROWN;
K:SMA(SMA( RSV,3,1),3,1),COLORWHITE;
D:MA(EMA(K,3),3),COLORYELLOW;
J:3*K-2*D,COLORMAGENTA;
A11:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A11+1)>C AND REF(DIF,A11+1)<DIF AND CROSS(DIF,DEA);
A12:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A12+1)>C AND REF("KDJ.K",A12+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
A13:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A13+1)>C AND REF("RSI.RSI1",A13+1)<"RSI.RSI1"AND CROSS("RSI.RSI1","RSI.RSI2");
C1:=BARSLAST(REF(CROSS(DEA,DIF),1));
D1:=REF(C,C1+1)<C AND REF(DIF,C1+1)>DIF AND CROSS(DEA,DIF);
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
MACD底背:IF(B1>0,50,0),LINETHICK2,COLORRED;
DRAWTEXT(B1>0,50,'M底背'),COLORRED;
KDJ底背:IF(B2>0,65,0),LINETHICK2,COLORFF00FF;

 

DRAWTEXT(B2>0,65,'K底背'),COLORFF00FF;
RSI底背:IF(B3>0,80,0),LINETHICK2,COLORYELLOW;
DRAWTEXT(B3>0,80,'R底背'),COLORYELLOW;
MACD頂背:IF(D1>0,-50,0),LINETHICK2,COLOR00FF00;
DRAWTEXT(D1>0,-50,'M頂背'),COLOR00FF00;
KDJ頂背:IF(D2>0,-65,0),LINETHICK2,COLORFFCC66;
DRAWTEXT(D2>0,-65,'K頂背'),COLORFFCC66;
RSI頂背:IF(D3>0,-80,0),LINETHICK2,COLORWHITE;
DRAWTEXT(D3>0,-80,'R頂背'),COLORWHITE;
DRAWICON((CROSS(K,D)
AND K<0 ),REF(K,1),8);
DRAWICON((CROSS(D,K) AND K>0
),D*1.05,7);


解答如下:

RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*247.2-123.6;
K:=SMA(SMA( RSV,3,1),3,1);
D:=MA(EMA(K,3),3);
CROSS(K,D) AND K<0 ;
 

 


免責聲明:本文系轉載,版權歸原作者所有;旨在傳遞信息,不代表本站的觀點和立場。

熱門TAGS

更多>>
公式頻道
股票軟件
配資資訊
財經頻道
股票開戶
理財頻道
股票入門
技術分析
技術進階
高手養成
配資平臺
亚洲欧美日产综合在线网